summaryrefslogtreecommitdiffstats
path: root/tests/manual/surfacetest/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Korpipaa <tomi.korpipaa@qt.io>2021-06-07 14:16:56 +0300
committerTomi Korpipaa <tomi.korpipaa@qt.io>2021-06-08 13:59:10 +0300
commitb05f048801ac41331e83faed13611a667160ffd5 (patch)
tree98f9a3e540bc240736ee0585e3ee5d2017de4fba /tests/manual/surfacetest/CMakeLists.txt
parentc0fd354690a6de2923e975bb4586fa5bbf310bb1 (diff)
Fix manual test builds
Fixes: QTBUG-94256 Change-Id: I3747f1cf94925d3818f277521473cee086eb3082 Reviewed-by: Miikka Heikkinen <miikka.heikkinen@qt.io>
Diffstat (limited to 'tests/manual/surfacetest/CMakeLists.txt')
-rw-r--r--tests/manual/surfacetest/CMakeLists.txt30
1 files changed, 18 insertions, 12 deletions
diff --git a/tests/manual/surfacetest/CMakeLists.txt b/tests/manual/surfacetest/CMakeLists.txt
index 1555b70d..c59f9488 100644
--- a/tests/manual/surfacetest/CMakeLists.txt
+++ b/tests/manual/surfacetest/CMakeLists.txt
@@ -1,28 +1,34 @@
-qt_add_executable(surfacetest
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+qt_internal_add_manual_test(surfacetest
GUI
SOURCES
graphmodifier.cpp graphmodifier.h
main.cpp
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Widgets
- Qt::DataVisualization
-)
+ )
+target_link_libraries(surfacetest PUBLIC
+ Qt::Gui
+ Qt::Widgets
+ Qt::DataVisualization
+ )
set_source_files_properties("Heightmap.png"
PROPERTIES QT_RESOURCE_ALIAS "map"
-)
+ )
set_source_files_properties("mapimage.png"
PROPERTIES QT_RESOURCE_ALIAS "mapimage"
-)
+ )
set(surfacetest_resource_files
"Heightmap.png"
"mapimage.png"
-)
+ )
qt_internal_add_resource(surfacetest "surfacetest"
PREFIX
- "/maps"
+ "/maps"
FILES
- ${surfacetest_resource_files}
-)
+ ${surfacetest_resource_files}
+ )