summaryrefslogtreecommitdiffstats
path: root/examples/datavisualization/qmllegend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/datavisualization/qmllegend/CMakeLists.txt')
-rw-r--r--examples/datavisualization/qmllegend/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/examples/datavisualization/qmllegend/CMakeLists.txt b/examples/datavisualization/qmllegend/CMakeLists.txt
deleted file mode 100644
index 2c3f56f0..00000000
--- a/examples/datavisualization/qmllegend/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-cmake_minimum_required(VERSION 3.14)
-project(qmllegend LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS DataVisualization)
-
-qt_add_executable(qmllegend
- main.cpp
-)
-set_target_properties(qmllegend PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(qmllegend PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::DataVisualization
-)
-
-set(qmllegend_resource_files
- "qml/qmllegend/Data.qml"
- "qml/qmllegend/LegendItem.qml"
- "qml/qmllegend/main.qml"
-)
-
-qt6_add_resources(qmllegend "qmllegend"
- PREFIX
- "/"
- FILES
- ${qmllegend_resource_files}
-)
-
-install(TARGETS qmllegend
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)