summaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmltest/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/qmltest/CMakeLists.txt b/tests/auto/qmltest/CMakeLists.txt
index 8ab433b4..3a53e40f 100644
--- a/tests/auto/qmltest/CMakeLists.txt
+++ b/tests/auto/qmltest/CMakeLists.txt
@@ -1,9 +1,15 @@
+file(GLOB_RECURSE test_data_glob
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ *)
+list(APPEND test_data ${test_data_glob})
+
qt_internal_add_test(tst_qmltest
QMLTEST
SOURCES
tst_qmltest.cpp
PUBLIC_LIBRARIES
Qt::Gui
+ TESTDATA ${test_data}
)
set(qmltest_resource_files