summaryrefslogtreecommitdiffstats
path: root/tests/manual/qmlgradient/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qmlgradient/CMakeLists.txt')
-rw-r--r--tests/manual/qmlgradient/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/manual/qmlgradient/CMakeLists.txt b/tests/manual/qmlgradient/CMakeLists.txt
new file mode 100644
index 00000000..067741e2
--- /dev/null
+++ b/tests/manual/qmlgradient/CMakeLists.txt
@@ -0,0 +1,24 @@
+qt_add_executable(qmlgradient
+ GUI
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::DataVisualization
+)
+
+set(qmlgradient_resource_files
+ "qml/qmlgradient/main.qml"
+ "crater.png"
+)
+
+set_source_files_properties("crater.png"
+ PROPERTIES QT_RESOURCE_ALIAS "map"
+)
+
+qt_add_resource(qmlgradient "qmlgradient"
+ PREFIX
+ "/"
+ FILES
+ ${qmlgradient_resource_files}
+)