summaryrefslogtreecommitdiffstats
path: root/tests/manual/scattertest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/scattertest/CMakeLists.txt')
-rw-r--r--tests/manual/scattertest/CMakeLists.txt18
1 files changed, 12 insertions, 6 deletions
diff --git a/tests/manual/scattertest/CMakeLists.txt b/tests/manual/scattertest/CMakeLists.txt
index 46f7b1de..00177653 100644
--- a/tests/manual/scattertest/CMakeLists.txt
+++ b/tests/manual/scattertest/CMakeLists.txt
@@ -1,10 +1,16 @@
-qt_add_executable(scattertest
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+qt_internal_add_manual_test(scattertest
GUI
SOURCES
main.cpp
scatterchart.cpp scatterchart.h
- PUBLIC_LIBRARIES
- Qt::Gui
- Qt::Widgets
- Qt::DataVisualization
-)
+ )
+target_link_libraries(scattertest PUBLIC
+ Qt::Gui
+ Qt::Widgets
+ Qt::DataVisualization
+ )