aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-08-27 10:19:50 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-08-27 08:24:18 +0000
commitb9a263faec1a0d94b76450a52c5ca07503e7e528 (patch)
tree7ef59c0084273fe85031a7811044707f3ecaadc0 /CMakeLists.txt
parentb938edcfb3aa2c78e35c9d63d995f6824e14eadf (diff)
Bump minimum CMake version to 3.15.0 as it is done in qtbase
We decided this in a workshop a while ago, where we noticed that the find_dependency() macro was broken in regards to finding additional components. 3.15.0 was the version that fixed it. Change-Id: Icdb161c983aea4f61fe705856428e5c3d443c05f Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b64790c9f5..07da25c5b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.14.0)
+cmake_minimum_required(VERSION 3.15.0)
project(QtDeclarative
VERSION 6.0.0