aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-09-17 16:47:03 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-17 14:56:09 +0000
commitf6229fea92db41daf4c567eee315bede0ecb6a26 (patch)
treefb8f312c77599156fe7f55f273a13e80528ef18b /CMakeLists.txt
parentb1299f6a83d2a2c6aaf8b28b8cf774a1e881aa49 (diff)
Fix top-level build with examples enabled
One of our examples depends on QtQuickTest, which has a public dependency to QtTest. So the example does find_package(Qt6 COMPONENTS QuickTest), which will end up calling find_dependency(QtTest). The Qt6Test cmake config files will import the module's feature, which requires the Qt6::Test target to exist. That however was not created because we set the QT_NO_CREATE_TARGETS. So if we set that (which is correct), then we do need to find Qt6::Test at the top-level. Other modules shouldn't need this as they don't create modules that in turn have a public dependency to testlib. Change-Id: Ia82aaa2b2462feec81659c6e532d0a185e6819a6 Done-with: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55b9a1943b..2939fe51d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,6 @@ project(QtDeclarative
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network
- OPTIONAL_COMPONENTS Sql Concurrent)
+ OPTIONAL_COMPONENTS Sql Concurrent Test)
qt_build_repo()