aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-11-11 15:06:55 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-03-30 01:42:11 +0000
commit7e5942447bf3ba28343474e23e42e87e57d5cdb9 (patch)
tree9d1bb544be1de052f909dde374c795bae3f44845 /CMakeLists.txt
parentd872223fdfc11e72574eb36c86830127b9211f49 (diff)
Add cmake support for examples
qml-i18n needed to be ported to CMake first. It uses qt_add_translations introduced in 6.2 As a drive-by, move find_package calls from examples' CML to the top level CML, and make the QtSql dependency optional. Also make sure that we only add the dynamicscene example when the Quick target is available. Fixes: QTBUG-90964 Change-Id: Id357eb14e4704753386e01393300966eb89b4e86 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 612d988243496aa1fc53442c0a385d633b411872) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3bf7d25cd..8dae927256 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ project(QtDeclarative # special case
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test LanguageServerPrivate)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test LanguageServerPrivate LinguistTools)
# Set up QT_HOST_PATH as an extra root path to look for the ShaderToolsTools package
# when cross-compiling.