aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-06-11 14:45:11 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-06-14 11:43:36 +0200
commitd65c5e8f791b68962ac7762d54cb2be9c7e5822d (patch)
treeb77704eb889797426f28e8548aec6858cd62485d /CMakeLists.txt
parent1bae74dfa031ed12eb3ca002040559425571303f (diff)
Remove unneeded CMake variable assignments
Remove assignments to the transitionary variables QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS and QT_USE_FIXED_QT_ADD_RESOURCE_BASE. Both are not needed anymore. Task-number: QTBUG-94444 Change-Id: I9236056e5e2a4386242a8437580255d0713fd1bf Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c6596342c..a0ffc0a99a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,14 +10,6 @@ project(QtDeclarative # special case
LANGUAGES CXX C
)
-# special case begin
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-
-# Make sure we use the fixed BASE argument of qt_add_resource.
-set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
-# special case end
-
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test)