aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-17 11:57:33 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-21 16:31:38 +0200
commit4ea5a0b72323614c436f8e8f03d4da64745247c2 (patch)
tree6efdd1782ae17d967aa7f402b81e4e262b9f3bfe /CMakeLists.txt
parent97f6ee941ba6e3a1e16ee2067261c4d8c4cbb556 (diff)
Use fixed qt_add_resource BASE argument
Fixes: QTBUG-93849 Task-number: QTBUG-86726 Change-Id: If6e1033642d98ccd40daeb57a453c0e5bc2985da Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> (cherry picked from commit 1917a868d9bbd6c916e2a54cad6ad28780f73f34)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd17f4a3c1..b8e843afb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,9 @@ project(QtDeclarative # special case
# special case begin
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
# special case end
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case