aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-02-03 13:39:01 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2020-02-05 09:45:33 +0000
commit49dbef650e2eedf178e310ac78eaba95f400584e (patch)
tree602a8d9cd080425ade09708d05d07048c04d8ff0 /CMakeLists.txt
parent016ce368086d57004ef041147bc9bed3a40dda7a (diff)
Move OpenGL to optional component
Parts of declarative is still buildable without OpenGL Change-Id: If76be1eaca03a4754d1d6a86c3d8fba3329bc773 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0f120aa5d..cfd53e07b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,8 @@ project(QtDeclarative
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network OpenGL # special case
- OPTIONAL_COMPONENTS Sql Concurrent Test) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network # special case
+ OPTIONAL_COMPONENTS OpenGL Sql Concurrent Test) # special case
# export QT6_ADD_QML_MODULE to this project
include(src/qml/Qt6QmlMacros.cmake)