aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2019-08-30 13:13:37 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-09-02 11:23:38 +0000
commit729addd82ecb30825097961022d189e956a2e2cf (patch)
tree126efc5863e76eac0cfc08fd89d6372492a47ec4 /CMakeLists.txt
parentb9a263faec1a0d94b76450a52c5ca07503e7e528 (diff)
Support standalone tests building
Also fix some build issues regarding tests. Change-Id: Ie9ba8a0b7932ae2b542614b6c824c4071ad0b548 Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07da25c5b2..55b9a1943b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,7 @@ project(QtDeclarative
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG COMPONENTS Sql)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network
+ OPTIONAL_COMPONENTS Sql Concurrent)
+
qt_build_repo()