aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-20 15:52:52 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-21 11:25:26 +0200
commit8ba6cf600e7c3037016a6861aa429326d5c9095b (patch)
treeb7c91453a2c337aa7e9806f26e4e103ae2740997 /CMakeLists.txt
parent06ad243417a7133fa0cbe32f17703cd5943a7a4e (diff)
CMake: Fix no-widgets build
Task-number: QTBUG-86053 Change-Id: If58d5b69ed58ae1aa3d50737683e682d70c26c23 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fd22daa2a..fd17f4a3c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,8 +15,8 @@ project(QtDeclarative # special case
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
# special case end
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network # special case
- OPTIONAL_COMPONENTS OpenGL OpenGLWidgets Sql Concurrent Test) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Network Widgets OpenGL OpenGLWidgets Sql Concurrent Test) # special case
# special case begin
# export QT6_ADD_QML_MODULE to this project