aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 15:29:14 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-24 14:56:24 +0200
commitcb6c4223953a725675f05c6d589ea4117ca1c450 (patch)
tree08476eb5c5ff7cd158946008e1e1e4a8d960e182 /CMakeLists.txt
parentcf5fc9d0c3fa616c37d626089766fec0257b2f16 (diff)
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Task-number: QTBUG-95018 Change-Id: Ic92ef51132db78f07891d3bab190078e9d3078b6 Reviewed-by: Kai Koehne <kai.koehne@qt.io> (cherry picked from commit 5a8b5f59e4335c5e230ee179b5f680c73a3607d3) Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a3ab1cf26..186d0a29f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtdeclarative.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtDeclarative # special case