aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-09-07 14:41:03 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-09-09 14:30:22 +0200
commit25ea9bbec2ffacf8f0554de91fb0960be28b5c8c (patch)
tree68ac85d0b4727c6abc2e57a51db28c13274ece9a /CMakeLists.txt
parentc80c0d212f048f16d3df5c2510bb0d568e5d1e4f (diff)
Use _qt_internal_collect_qml_root_paths to collect android dependencies
Add the _qt_internal_collect_qml_root_paths function that collects qml root paths and sets the QT_QML_ROOT_PATH property to the target based on the provided qml source files. Call _qt_internal_collect_qml_root_paths when adding QML source files to collect QML root paths for the qmlimportscanner when building Android applications. Pick-to: 6.2 Task-number: QTBUG-93340 Change-Id: Ica996e6043b5d1b403665a1316eff23dc97fdf44 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f147cb464..450a18f0e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,9 @@ endif()
# special case begin
# export QT6_ADD_QML_MODULE to this project
include(src/qml/Qt6QmlMacros.cmake)
+if(ANDROID)
+ include("${CMAKE_CURRENT_LIST_DIR}/src/qml/Qt6AndroidQmlMacros.cmake")
+endif()
# special case end
if(NOT QT_FEATURE_commandlineparser)