aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-22 15:48:56 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-06 13:19:45 +0200
commit4dcbdf422f5985a03cd386e9a17da87f1350de84 (patch)
treedab68a6dec2ff3c28437b179e2285e6626b0d01f /CMakeLists.txt
parent08adbefa131ef1c934f55cd61716c8ea836ddf02 (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I3d80bf0ffcfe765472b2cd01ffc43d3af04d0261 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aad689a5a7..2fd22daa2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@ project(QtDeclarative # special case
LANGUAGES CXX C
)
+# special case begin
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+# special case end
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets Network # special case
OPTIONAL_COMPONENTS OpenGL OpenGLWidgets Sql Concurrent Test) # special case