aboutsummaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-22 11:45:45 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-23 13:51:06 +0000
commitb938edcfb3aa2c78e35c9d63d995f6824e14eadf (patch)
tree593a1eb2158d47b67d422259721198956d9f9a7f /examples/CMakeLists.txt
parent2be575b4b1e6f6e11a8dbd0b1c05c003828d2598 (diff)
Convert Examples
This patch converts all examples in qtdeclarative except for a few exceptions which require a public facing qml plugin api. Change-Id: I2cd2b1bb455be8b48796893a8235dea7f8b35aa2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt20
1 files changed, 13 insertions, 7 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 81892b1661..b6c19fb6e1 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,11 +1,17 @@
# Generated from examples.pro.
-add_subdirectory(qml)
+# special case begin
+qt_examples_build_begin()
+# special case end
-#if(TARGET Qt::QuickTest)
- #add_subdirectory(qmltest)
-#endif()
+add_subdirectory(qml)
+if(TARGET Qt::QuickTest)
+ add_subdirectory(qmltest)
+endif()
+if(TARGET Qt::Quick)
+ add_subdirectory(quick)
+endif()
-#if(TARGET Qt::Quick)
-#add_subdirectory(quick)
-#endif()
+# special case begin
+qt_examples_build_end()
+# special case end