aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/referenceexamples/methods/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-08-23 16:29:18 +1000
committerCraig Scott <craig.scott@qt.io>2021-08-25 10:44:35 +1000
commit58127aa35945dc76bd71b69b25d141025267f4c8 (patch)
tree0598b09ef3a806adefc2a789abb7766405a3a180 /examples/qml/referenceexamples/methods/CMakeLists.txt
parent938aebaa14c99e1f05d3a13530e924067cbe07a3 (diff)
Update qml examples for improved target path handling
Some examples were still using the old "add as ordinary resources" approach for QML modules, others needed adjustment to the subdirectory structure to better reflect the URI structure of the QML modules involved. Task-number: QTBUG-95144 Change-Id: Ie3399410cf6df491eb1e7b4a589ca26c577d82a0 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit 9e1d2a0eb15487f8f2acb4d91b281568897fb4e1)
Diffstat (limited to 'examples/qml/referenceexamples/methods/CMakeLists.txt')
-rw-r--r--examples/qml/referenceexamples/methods/CMakeLists.txt23
1 files changed, 5 insertions, 18 deletions
diff --git a/examples/qml/referenceexamples/methods/CMakeLists.txt b/examples/qml/referenceexamples/methods/CMakeLists.txt
index 0fc043fb8b..304aa3082a 100644
--- a/examples/qml/referenceexamples/methods/CMakeLists.txt
+++ b/examples/qml/referenceexamples/methods/CMakeLists.txt
@@ -32,17 +32,11 @@ target_link_libraries(methods PUBLIC
Qt::Qml
)
-
-# Resources:
-set(methods_resource_files
- "example.qml"
-)
-
-qt6_add_resources(methods "methods"
- PREFIX
- "/"
- FILES
- ${methods_resource_files}
+qt_add_qml_module(methods
+ URI People
+ VERSION 1.0
+ QML_FILES example.qml
+ NO_RESOURCE_TARGET_PATH
)
install(TARGETS methods
@@ -50,10 +44,3 @@ install(TARGETS methods
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
-
-set_target_properties(methods PROPERTIES
- QT_QML_MODULE_VERSION 1.0
- QT_QML_MODULE_URI People
-)
-
-qt6_qml_type_registration(methods)