aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/tutorials/extending-qml/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-22 11:45:45 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-23 13:51:06 +0000
commitb938edcfb3aa2c78e35c9d63d995f6824e14eadf (patch)
tree593a1eb2158d47b67d422259721198956d9f9a7f /examples/qml/tutorials/extending-qml/CMakeLists.txt
parent2be575b4b1e6f6e11a8dbd0b1c05c003828d2598 (diff)
Convert Examples
This patch converts all examples in qtdeclarative except for a few exceptions which require a public facing qml plugin api. Change-Id: I2cd2b1bb455be8b48796893a8235dea7f8b35aa2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/qml/tutorials/extending-qml/CMakeLists.txt')
-rw-r--r--examples/qml/tutorials/extending-qml/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/qml/tutorials/extending-qml/CMakeLists.txt b/examples/qml/tutorials/extending-qml/CMakeLists.txt
new file mode 100644
index 0000000000..8f8395ac95
--- /dev/null
+++ b/examples/qml/tutorials/extending-qml/CMakeLists.txt
@@ -0,0 +1,11 @@
+# Generated from extending-qml.pro.
+
+add_subdirectory(chapter1-basics)
+add_subdirectory(chapter2-methods)
+add_subdirectory(chapter3-bindings)
+add_subdirectory(chapter4-customPropertyTypes)
+add_subdirectory(chapter5-listproperties)
+# special case begin
+# Needs public QML plugin API
+# add_subdirectory(chapter6-plugins)
+# special case end