aboutsummaryrefslogtreecommitdiffstats
path: root/examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-01-28 23:38:38 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-01-29 15:39:22 +0000
commit97a5cf86345fd72cdff83c03664c19a8f5cdf79a (patch)
tree2ce6946c3ad4ceafb91aeab434dc36cf3473d370 /examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt
parent12f0381a34a9fb4548e9b30c987f44848adc1f67 (diff)
Regenerate examples
Change-Id: I39564d4b644a7ee367d9ce92b85426a5c2a122a4 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt')
-rw-r--r--examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt b/examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt
index 8441aa9fb3..30b9fee0cb 100644
--- a/examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt
+++ b/examples/qml/tutorials/extending-qml/chapter2-methods/CMakeLists.txt
@@ -45,3 +45,11 @@ install(TARGETS chapter2-methods
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+set_target_properties(chapter2-methods PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION 1.0
+ QT_QML_MODULE_URI Charts
+)
+
+qt6_qml_type_registration(chapter2-methods)