aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-23 16:55:11 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-29 16:14:44 +0200
commitd73f98b1b560ce9776250f0a81c37682de0c8190 (patch)
tree400883b40023840731da803db1a55037f1e310bc /examples/quick/customitems/painteditem/CMakeLists.txt
parentedc4357ae4893dd952ce1c07b180b4b334047606 (diff)
CMake: Fix textballoon example when using a static Qt
Don't pre-create a qml module backing library, don't link to it directly and instead rely on regular qml plugin loading. This avoids undefined linker errors. Amends 79cae5f6522bc259caa27b98031bfe84ef936744 Pick-to: 6.2 Fixes: QTBUG-96805 Change-Id: I77acd086257e27e1933e9b36d7f0212765afceb3 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/quick/customitems/painteditem/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/quick/customitems/painteditem/CMakeLists.txt b/examples/quick/customitems/painteditem/CMakeLists.txt
index 63becfa53d..db2a02b25a 100644
--- a/examples/quick/customitems/painteditem/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/CMakeLists.txt
@@ -28,8 +28,8 @@ target_link_libraries(painteditemexample PRIVATE
Qt::Gui
Qt::Qml
Qt::Quick
- qmltextballoon
)
+add_dependencies(painteditemexample qmltextballoon)
install(TARGETS painteditemexample
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"