aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-20 17:42:48 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-01-24 23:33:49 +0000
commiteb8d3d37ef2e5d208f5c456a76738d847e1496b2 (patch)
treece4b65b0b9c91bb325d54ff69e6121111205cbe1 /examples/quick/customitems/painteditem/CMakeLists.txt
parent7d922aec2133d8e9b08bd2ffb10b1721716d451e (diff)
Improve examples CMakeLists.txt
- Remove # generated from xyz.pro comment from pro2cmake - Remove "# special case" markers for pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Change-Id: I0d6bfb06c4b25e9921d3d2bf31d977150f12b31b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit 9d82f4bff8520c3f6db7790d9044c3dfc5cc84c0) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/quick/customitems/painteditem/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/quick/customitems/painteditem/CMakeLists.txt b/examples/quick/customitems/painteditem/CMakeLists.txt
index 8299de4882..d7903b4d15 100644
--- a/examples/quick/customitems/painteditem/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/CMakeLists.txt
@@ -5,12 +5,12 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/customitems/painteditem")
-find_package(Qt6 COMPONENTS Core Gui Quick Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
add_subdirectory(TextBalloon)
@@ -29,6 +29,7 @@ target_link_libraries(painteditemexample PRIVATE
Qt::Qml
Qt::Quick
)
+
add_dependencies(painteditemexample qmltextballoon)
install(TARGETS painteditemexample