aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/customitems/painteditem/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-23 16:55:11 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-29 16:14:44 +0200
commit73d8a2c01667d1c1ac11d5bf0121b3a144ceb5f1 (patch)
tree42a1868f24324049d88028d45efdcc309192989f /examples/quick/customitems/painteditem/CMakeLists.txt
parent7ab424a5cd7790dd87eabd68c294d38662aca8fe (diff)
CMake: Fix textballoon example when using a shared Qt on macOS
Copy the qml plugin into the macOS app bundle just like we do for the examples that use the 'shared' project using the new add_qml_module_to_macos_app_bundle helper function. Amends 79cae5f6522bc259caa27b98031bfe84ef936744 Pick-to: 6.2 Fixes: QTBUG-96805 Change-Id: Ib22131a15f0cd06a7888ec991f5ec9f79045d202 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/quick/customitems/painteditem/CMakeLists.txt')
-rw-r--r--examples/quick/customitems/painteditem/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/quick/customitems/painteditem/CMakeLists.txt b/examples/quick/customitems/painteditem/CMakeLists.txt
index db2a02b25a..8299de4882 100644
--- a/examples/quick/customitems/painteditem/CMakeLists.txt
+++ b/examples/quick/customitems/painteditem/CMakeLists.txt
@@ -36,3 +36,11 @@ install(TARGETS painteditemexample
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+
+include(../../shared/QtBundleQmlModuleForMacOS.cmake)
+
+set(app_target "painteditemexample")
+set(qml_plugin_target "qmltextballoon")
+set(qml_module_uri "TextBalloon")
+add_qml_module_to_macos_app_bundle(
+ "${app_target}" "${qml_plugin_target}" "${qml_module_uri}")