aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/imageresponseprovider/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 17:09:47 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 23:38:39 +0100
commit20d5e2d7efd458671e2830e94cd8bc30e14361e5 (patch)
treeb0cfe10bb101ee56eb1c2c4d0750fc33819aa324 /examples/quick/imageresponseprovider/CMakeLists.txt
parent880b937b6c67df35eea46cec9f4580dc79e21a99 (diff)
CMake: Regenerate examples to set the WIN32_EXECUTABLE property
As well as the MACOSX_BUNDLE properties as necessary. Task-number: QTBUG-87664 Task-number: QTBUG-86827 Change-Id: I46769fb543acb2cbeba122470b5e44ad478fbe4e Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/quick/imageresponseprovider/CMakeLists.txt')
-rw-r--r--examples/quick/imageresponseprovider/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/quick/imageresponseprovider/CMakeLists.txt b/examples/quick/imageresponseprovider/CMakeLists.txt
index 328dc321f1..5f282a0fb9 100644
--- a/examples/quick/imageresponseprovider/CMakeLists.txt
+++ b/examples/quick/imageresponseprovider/CMakeLists.txt
@@ -30,6 +30,10 @@ qt6_add_qml_module(qmlimageresponseproviderplugin
target_sources(qmlimageresponseproviderplugin PRIVATE
imageresponseprovider.cpp
)
+set_target_properties(qmlimageresponseproviderplugin PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(qmlimageresponseproviderplugin PUBLIC
Qt::Core
Qt::Gui