aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/localstorage/localstorage/CMakeLists.txt
diff options
context:
space:
mode:
authorOliver Eftevaag <oliver.eftevaag@qt.io>2021-09-01 15:40:28 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-09-03 15:10:39 +0000
commitce546cdd8c0d8b5175af81e7cf7f06f9b56cfeed (patch)
tree5cbe853f922c8efc2d5cfea94a2cb7d45cc579ed /examples/quick/localstorage/localstorage/CMakeLists.txt
parent3aea6644d47b82784b01b5268eda2fad8c28b5c9 (diff)
Fix localstorage example to use a QML module
Removing the directory 'localstorage' that is inside the top-level 'localstorage' directory, and moving the content one level up in the file hierarchy. Change-Id: I97cf1ff92be9860d9a92bce66c88af927618e2b0 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io> (cherry picked from commit b0e567e7e3927945c904e9a613af4b9064d70bc1) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/quick/localstorage/localstorage/CMakeLists.txt')
-rw-r--r--examples/quick/localstorage/localstorage/CMakeLists.txt58
1 files changed, 0 insertions, 58 deletions
diff --git a/examples/quick/localstorage/localstorage/CMakeLists.txt b/examples/quick/localstorage/localstorage/CMakeLists.txt
deleted file mode 100644
index a67f80c4ea..0000000000
--- a/examples/quick/localstorage/localstorage/CMakeLists.txt
+++ /dev/null
@@ -1,58 +0,0 @@
-# Generated from localstorage.pro.
-
-cmake_minimum_required(VERSION 3.16)
-project(localstorage LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/localstorage/localstorage")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS Qml)
-
-qt_add_executable(localstorage
- main.cpp
-)
-set_target_properties(localstorage PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_link_libraries(localstorage PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
-)
-
-
-# Resources:
-set(localstorage_resource_files
- "Database.js"
- "Header.qml"
- "MyDelegate.qml"
- "MyModel.qml"
- "localstorage.qml"
-)
-
-qt6_add_resources(localstorage "localstorage"
- PREFIX
- "/"
- FILES
- ${localstorage_resource_files}
-)
-
-install(TARGETS localstorage
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)