aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/mousearea/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:27:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:28:15 +0100
commit8592ae4096f3f9c2b08b87ad2fcbbbfadf75f2d7 (patch)
treea757c1d80ec77952eae2cc4de5d89c01f14760fc /examples/quick/mousearea/CMakeLists.txt
parente7decc7637e9eb7e66a0d19705090f18488028c0 (diff)
parent14492ecee2e34843efd3ef070503a43a48552055 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Conflicts: dependencies.yaml Change-Id: Ifff48b9d0e7962d481e63c49399e2d304e1011e5
Diffstat (limited to 'examples/quick/mousearea/CMakeLists.txt')
-rw-r--r--examples/quick/mousearea/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/examples/quick/mousearea/CMakeLists.txt b/examples/quick/mousearea/CMakeLists.txt
new file mode 100644
index 0000000000..82a1d2fb35
--- /dev/null
+++ b/examples/quick/mousearea/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from mousearea.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(mousearea LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/mousearea")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(mousearea
+ main.cpp
+)
+target_link_libraries(mousearea PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(mousearea_resource_files
+ "mousearea-wheel-example.qml"
+ "mousearea.qml"
+)
+
+qt6_add_resources(mousearea "mousearea"
+ PREFIX
+ "/mousearea"
+ FILES
+ ${mousearea_resource_files}
+)
+
+install(TARGETS mousearea
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)