aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/rendercontrol/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Agocs <laszlo.agocs@qt.io>2020-03-23 19:19:20 +0100
committerLaszlo Agocs <laszlo.agocs@qt.io>2020-03-24 17:03:12 +0100
commit1a1028a1e4ca3d0d932141f265d01284e013a76a (patch)
tree83800f1479313350b31d5e334cb2a6bee4e2a427 /examples/quick/rendercontrol/CMakeLists.txt
parent40e27dd54772e8b0f72d91c773d37118ba0d4651 (diff)
Move legacy rendercontrol example into a subdirectory
...called rendercontrol_opengl under examples/quick/rendercontrol. This example is going to be migrated to support operating with RHI-on-OpenGL later on. Additionally, we can this way introduce more rendercontrol examples in the future, for example to show how to do things with Vulkan, Metal, D3D. Task-number: QTBUG-78595 Change-Id: I7f5243b1f86e62949400107bf12bfa07b17b1031 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io>
Diffstat (limited to 'examples/quick/rendercontrol/CMakeLists.txt')
-rw-r--r--examples/quick/rendercontrol/CMakeLists.txt48
1 files changed, 1 insertions, 47 deletions
diff --git a/examples/quick/rendercontrol/CMakeLists.txt b/examples/quick/rendercontrol/CMakeLists.txt
index 8f1067a7b5..bfcd71de24 100644
--- a/examples/quick/rendercontrol/CMakeLists.txt
+++ b/examples/quick/rendercontrol/CMakeLists.txt
@@ -1,49 +1,3 @@
# Generated from rendercontrol.pro.
-cmake_minimum_required(VERSION 3.14)
-project(rendercontrol LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples/quick/rendercontrol")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS Qml)
-
-add_qt_gui_executable(rendercontrol
- cuberenderer.cpp cuberenderer.h
- main.cpp
- window_multithreaded.cpp window_multithreaded.h
- window_singlethreaded.cpp window_singlethreaded.h
-)
-target_link_libraries(rendercontrol PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
-)
-
-
-# Resources:
-set(rendercontrol_resource_files
- "demo.qml"
-)
-
-qt6_add_resources(rendercontrol "rendercontrol"
- PREFIX
- "/rendercontrol"
- FILES
- ${rendercontrol_resource_files}
-)
-
-install(TARGETS rendercontrol
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)
+add_subdirectory(rendercontrol_opengl)