aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorLaszlo Agocs <laszlo.agocs@qt.io>2020-05-06 18:56:01 +0200
committerLaszlo Agocs <laszlo.agocs@qt.io>2020-05-18 16:09:55 +0200
commit3475b5f3a80545dfbd4746295e8e1ae88c7114ca (patch)
tree0e3e14ae5cd4708a76beaf522eb9f7214ce5d8fd /examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt
parent1c5de027d0c31d1d6697bd0557128d92207763d8 (diff)
Modernize the rendercontrol_opengl example
Make it work when using QRhi-on-OpenGL. Some features like demonstrating a dedicated render thread, or targeting the window with the Quick content ('onscreen' argument, not clear why that was added in the first place), are now removed. Some of these could be reintroduced in future examples, not necessarily in combination with OpenGL. For now they are removed since the cost of porting and maintaining all that is not reasonable at this point. Task-number: QTBUG-84040 Change-Id: I67e5c7cc835c5cf5653cf827004ce66a4d300b36 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io>
Diffstat (limited to 'examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt')
-rw-r--r--examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt b/examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt
index fb1c6ecf12..310f721f2e 100644
--- a/examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt
+++ b/examples/quick/rendercontrol/rendercontrol_opengl/CMakeLists.txt
@@ -15,16 +15,17 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Quick)
find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS OpenGL)
add_qt_gui_executable(rendercontrol_opengl
cuberenderer.cpp cuberenderer.h
main.cpp
- window_multithreaded.cpp window_multithreaded.h
window_singlethreaded.cpp window_singlethreaded.h
)
target_link_libraries(rendercontrol_opengl PUBLIC
Qt::Core
Qt::Gui
+ Qt::OpenGL
Qt::Qml
Qt::Quick
)