aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/d3d11underqml/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-08-23 18:26:06 +1000
committerCraig Scott <craig.scott@qt.io>2021-08-24 16:08:21 +1000
commita86fd709dd4d315cfe4fea77ea0bc730131fe840 (patch)
treed63e9a2240f00f298905b11cddcac49cb0ee25be /examples/quick/scenegraph/d3d11underqml/CMakeLists.txt
parent9e1d2a0eb15487f8f2acb4d91b281568897fb4e1 (diff)
Update quick examples to new QML CMake API
This is a pre-requisite to being able to make qt6_qml_type_registration() an internal rather than public command. Not all examples have been updated, only those that were using the qt6_qml_type_registration() command. Task-number: QTBUG-95093 Pick-to: 6.2 Change-Id: I3f1814a29af608461daa90477eca0aa2304eb9d1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/quick/scenegraph/d3d11underqml/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/d3d11underqml/CMakeLists.txt30
1 files changed, 10 insertions, 20 deletions
diff --git a/examples/quick/scenegraph/d3d11underqml/CMakeLists.txt b/examples/quick/scenegraph/d3d11underqml/CMakeLists.txt
index fd9e78a738..74e077a7a5 100644
--- a/examples/quick/scenegraph/d3d11underqml/CMakeLists.txt
+++ b/examples/quick/scenegraph/d3d11underqml/CMakeLists.txt
@@ -37,19 +37,16 @@ target_link_libraries(d3d11underqml PUBLIC
d3dcompiler
)
-
-# Resources:
-set(d3d11underqml_resource_files
- "main.qml"
- "squircle.frag"
- "squircle.vert"
-)
-
-qt6_add_resources(d3d11underqml "d3d11underqml"
- PREFIX
- "/scenegraph/d3d11underqml"
- FILES
- ${d3d11underqml_resource_files}
+qt_add_qml_module(d3d11underqml
+ URI D3D11UnderQML
+ VERSION 1.0
+ QML_FILES
+ main.qml
+ RESOURCES
+ squircle.frag
+ squircle.vert
+ RESOURCE_PREFIX /scenegraph/d3d11underqml
+ NO_RESOURCE_TARGET_PATH
)
install(TARGETS d3d11underqml
@@ -57,10 +54,3 @@ install(TARGETS d3d11underqml
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
-
-set_target_properties(d3d11underqml PROPERTIES
- QT_QML_MODULE_VERSION 1.0
- QT_QML_MODULE_URI D3D11UnderQML
-)
-
-qt6_qml_type_registration(d3d11underqml)