aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/fboitem/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-14 18:46:38 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-14 19:02:37 +0200
commitc2f8b9535d34da6948ccf45b7d5fd90de2f1bc9e (patch)
treec6f7e058a985d7c18b51cadc76283caf555071c9 /examples/quick/scenegraph/fboitem/CMakeLists.txt
parent9e633bbda7608ac0231809e2a6a97ae8f2d849d6 (diff)
parent803f18f02e5609a1ca00a5b78ea6d3613d44e1a0 (diff)
Merge remote-tracking branch 'origin/dev' into wip/cmake
Removed dependencies.yaml because we don't use it yet in wip/cmake. Fixed conflict in qmlcachegen.cpp. Change-Id: Ie1060c737bee1daa85779903598e5b6d5020d922
Diffstat (limited to 'examples/quick/scenegraph/fboitem/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/fboitem/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/fboitem/CMakeLists.txt b/examples/quick/scenegraph/fboitem/CMakeLists.txt
new file mode 100644
index 0000000000..1117ef22a9
--- /dev/null
+++ b/examples/quick/scenegraph/fboitem/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Generated from textureinsgnode.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(textureinsgnode LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/quick/scenegraph/textureinsgnode")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(textureinsgnode
+ ../shared/logorenderer.cpp ../shared/logorenderer.h
+ fboinsgrenderer.cpp fboinsgrenderer.h
+ main.cpp
+)
+target_include_directories(textureinsgnode PUBLIC
+ ../shared
+)
+
+target_link_libraries(textureinsgnode PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+
+# Resources:
+set(textureinsgnode_resource_files
+ "main.qml"
+)
+
+qt6_add_resources(textureinsgnode "textureinsgnode"
+ PREFIX
+ "/scenegraph/textureinsgnode"
+ FILES
+ ${textureinsgnode_resource_files}
+)
+
+install(TARGETS textureinsgnode
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)