aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-20 17:42:48 +0100
committerKai Köhne <kai.koehne@qt.io>2022-01-24 13:25:13 +0100
commit9d82f4bff8520c3f6db7790d9044c3dfc5cc84c0 (patch)
tree208f1e58e65083c7ddad2abdf1473679176fdaad /examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
parenta3924b9846f8f3412e6cfc3704f69488e64da98e (diff)
Improve examples CMakeLists.txt
- Remove # generated from xyz.pro comment from pro2cmake - Remove "# special case" markers for pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Pick-to: 6.3 Change-Id: I0d6bfb06c4b25e9921d3d2bf31d977150f12b31b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/quick/scenegraph/metaltextureimport/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/metaltextureimport/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
index eb3740f6ef..68451e292c 100644
--- a/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
+++ b/examples/quick/scenegraph/metaltextureimport/CMakeLists.txt
@@ -1,29 +1,21 @@
-# Generated from metaltextureimport.pro.
-
cmake_minimum_required(VERSION 3.16)
project(metaltextureimport LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/scenegraph/metaltextureimport")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS Quick)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
qt_add_executable(metaltextureimport
main.cpp
metaltextureimport.h metaltextureimport.mm
)
+
set_target_properties(metaltextureimport PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
@@ -31,6 +23,7 @@ set_target_properties(metaltextureimport PROPERTIES
# Prevent name clash with build subdirectory on case-insensitive file systems
OUTPUT_NAME metaltextureimportapp
)
+
target_link_libraries(metaltextureimport PUBLIC
"-framework Metal"
Qt::Core