aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/scenegraph/twotextureproviders/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-22 11:45:45 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-23 13:51:06 +0000
commitb938edcfb3aa2c78e35c9d63d995f6824e14eadf (patch)
tree593a1eb2158d47b67d422259721198956d9f9a7f /examples/quick/scenegraph/twotextureproviders/CMakeLists.txt
parent2be575b4b1e6f6e11a8dbd0b1c05c003828d2598 (diff)
Convert Examples
This patch converts all examples in qtdeclarative except for a few exceptions which require a public facing qml plugin api. Change-Id: I2cd2b1bb455be8b48796893a8235dea7f8b35aa2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/quick/scenegraph/twotextureproviders/CMakeLists.txt')
-rw-r--r--examples/quick/scenegraph/twotextureproviders/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/examples/quick/scenegraph/twotextureproviders/CMakeLists.txt b/examples/quick/scenegraph/twotextureproviders/CMakeLists.txt
new file mode 100644
index 0000000000..b07da2ba2b
--- /dev/null
+++ b/examples/quick/scenegraph/twotextureproviders/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from twotextureproviders.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(twotextureproviders LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+add_qt_gui_executable(twotextureproviders
+ main.cpp
+ xorblender.cpp xorblender.h
+)
+target_link_libraries(twotextureproviders PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+)
+
+# Resources:
+set(twotextureproviders_resource_files
+ "main.qml"
+)
+
+QT6_ADD_RESOURCES(twotextureproviders "twotextureproviders"
+ PREFIX
+ "/scenegraph/twotextureproviders"
+ FILES
+ ${twotextureproviders_resource_files}
+)
+
+
+install(TARGETS twotextureproviders
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)