aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/tableview/gameoflife/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-08-23 18:26:06 +1000
committerCraig Scott <craig.scott@qt.io>2021-08-24 16:08:21 +1000
commita86fd709dd4d315cfe4fea77ea0bc730131fe840 (patch)
treed63e9a2240f00f298905b11cddcac49cb0ee25be /examples/quick/tableview/gameoflife/CMakeLists.txt
parent9e1d2a0eb15487f8f2acb4d91b281568897fb4e1 (diff)
Update quick examples to new QML CMake API
This is a pre-requisite to being able to make qt6_qml_type_registration() an internal rather than public command. Not all examples have been updated, only those that were using the qt6_qml_type_registration() command. Task-number: QTBUG-95093 Pick-to: 6.2 Change-Id: I3f1814a29af608461daa90477eca0aa2304eb9d1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/quick/tableview/gameoflife/CMakeLists.txt')
-rw-r--r--examples/quick/tableview/gameoflife/CMakeLists.txt25
1 files changed, 6 insertions, 19 deletions
diff --git a/examples/quick/tableview/gameoflife/CMakeLists.txt b/examples/quick/tableview/gameoflife/CMakeLists.txt
index a5faa08470..f47c27a7ce 100644
--- a/examples/quick/tableview/gameoflife/CMakeLists.txt
+++ b/examples/quick/tableview/gameoflife/CMakeLists.txt
@@ -35,18 +35,12 @@ target_link_libraries(gameoflife PUBLIC
Qt::Quick
)
-
-# Resources:
-set(qmake_immediate_resource_files
- "gosperglidergun.cells"
- "main.qml"
-)
-
-qt6_add_resources(gameoflife "qmake_immediate"
- PREFIX
- "/"
- FILES
- ${qmake_immediate_resource_files}
+qt_add_qml_module(gameoflife
+ URI GameOfLifeModel
+ VERSION 1.0
+ QML_FILES main.qml
+ RESOURCES gosperglidergun.cells
+ NO_RESOURCE_TARGET_PATH
)
install(TARGETS gameoflife
@@ -54,10 +48,3 @@ install(TARGETS gameoflife
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
-
-set_target_properties(gameoflife PROPERTIES
- QT_QML_MODULE_VERSION 1.0
- QT_QML_MODULE_URI GameOfLifeModel
-)
-
-qt6_qml_type_registration(gameoflife)