aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/views/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-28 16:37:02 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 10:01:22 +0200
commit965984771d1c146a01fbaab3f6dae2461eabf78e (patch)
tree44022f6e8affb27a477e58fd29eebac6769c42f4 /examples/quick/views/CMakeLists.txt
parent476d1f57605a1d9867a87946d1cdf7bb3c1ced3a (diff)
CMake: Regenerate qtdeclarative/examples
Includes - new example installation paths - one case of QT_QMLTYPES_FILENAME addition Change-Id: I24423da9b04b6ecc8445017fa35f148dd43b1829 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'examples/quick/views/CMakeLists.txt')
-rw-r--r--examples/quick/views/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/quick/views/CMakeLists.txt b/examples/quick/views/CMakeLists.txt
index a53c977ab9..da38b18ec0 100644
--- a/examples/quick/views/CMakeLists.txt
+++ b/examples/quick/views/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/quick/views")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quick/views")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)