aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quick/views/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2021-09-01 15:53:43 +0200
committerUlf Hermann <ulf.hermann@qt.io>2021-09-03 13:04:55 +0200
commit633a85cd39cdd294283439972cffebcff32ac0cb (patch)
tree51da251a52dbaa431c491aa30d50a7d13ed0200d /examples/quick/views/CMakeLists.txt
parent483274ee3e259ddef19d0a00c004ec33c1a89276 (diff)
Install the "shared" example module into macOS bundles
If we build an application bundle we cannot rely on the relative path between the application's and the shared module's output directories. This is somewhat ugly, but as we don't have a comprehensive solution for building application bundles, yet, it's the best we can do right now. In order for the shared bundle to be loaded from the PlugIns directory, we need to add the PlugIns directory to the import path on macOS. Pick-to: 6.2 Change-Id: I5b952420b4bb60af74886a140fa2c6a263d2f730 Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'examples/quick/views/CMakeLists.txt')
-rw-r--r--examples/quick/views/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/quick/views/CMakeLists.txt b/examples/quick/views/CMakeLists.txt
index 18796e39ca..ca02f8d86e 100644
--- a/examples/quick/views/CMakeLists.txt
+++ b/examples/quick/views/CMakeLists.txt
@@ -95,3 +95,4 @@ install(TARGETS viewsexample
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+bundle_shared(viewsexample)