aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-04-28 13:21:38 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-03 12:32:40 +0200
commit222a5601a970cca20c45b043ad86d684ef3f01c1 (patch)
tree0c5dadd328f27cbdd15945a5d328c1e80f962508 /examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt
parent76372d0d0b84a1f594082ad4b27154ee2a314d76 (diff)
Examples: Use versioned CMake targets for Qt modules
Use e.g. Qt6::Core instead of Qt::Core. This is better matching the find_package(Qt6 ...) call, and also avoids issues that the versionless targets have. Task-number: QTBUG-113277 Change-Id: Ib80f885e9f73fb9ad54b9e9b22cae2318877dc07 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> (cherry picked from commit 2e6403f8bf950cf3e4802319e41ac1ae368c0586)
Diffstat (limited to 'examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt b/examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt
index 561861afc0..bc531ef529 100644
--- a/examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt
+++ b/examples/quickcontrols/chattutorial/chapter2/CMakeLists.txt
@@ -19,10 +19,10 @@ qt_add_executable(chattutorial-chapter2 WIN32 MACOSX_BUNDLE
)
target_link_libraries(chattutorial-chapter2 PRIVATE
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Qml
+ Qt6::Quick
)
qt_policy(SET QTP0001 NEW)