aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/filesystemexplorer/CMakeLists.txt
diff options
context:
space:
mode:
authorDennis Oberst <dennis.oberst@qt.io>2024-01-17 11:28:11 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2024-01-22 11:03:43 +0000
commit15d27caf011f6cf1392585e10ae4b925d0257aba (patch)
tree112a569fa3b4eaeae483349a30eb815698631ae3 /examples/quickcontrols/filesystemexplorer/CMakeLists.txt
parent083541a50d21273b1e2bc52df7da22c719c3c62a (diff)
Filesystem Explorer: Guard against mobile usage
It was observed that users try to run this example on mobile platforms. It was never designed for such a usecase and is therefore not supported. Ref: https://camg.me/qt-mobile-2023/#filesystem Additionally mention that this is a desktop example in the docs. Pick-to: 6.6 Change-Id: I55205e3f2cb3a45aaf18f2a52ea24f54ab8e39bd Reviewed-by: Mitch Curtis <mitch.curtis@qt.io> (cherry picked from commit 9e4f24e7491ebd8e26a7ca4d56046e558b57154c) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/quickcontrols/filesystemexplorer/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/filesystemexplorer/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/examples/quickcontrols/filesystemexplorer/CMakeLists.txt b/examples/quickcontrols/filesystemexplorer/CMakeLists.txt
index 53eeb7b4e6..4a676d28d8 100644
--- a/examples/quickcontrols/filesystemexplorer/CMakeLists.txt
+++ b/examples/quickcontrols/filesystemexplorer/CMakeLists.txt
@@ -4,6 +4,11 @@
cmake_minimum_required(VERSION 3.16)
project(filesystemexplorer LANGUAGES CXX)
+if (ANDROID OR IOS)
+ message(FATAL_ERROR "Platform is not supported")
+ return()
+endif ()
+
if (NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif ()