aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols/gallery/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-04-28 13:21:38 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-02 12:12:35 +0200
commit2e6403f8bf950cf3e4802319e41ac1ae368c0586 (patch)
tree732b271752f4b5840c4e485bb1dc9521542b4421 /examples/quickcontrols/gallery/CMakeLists.txt
parent8db22d191f6d153cfe950697e89f535062410b83 (diff)
Examples: Use versioned CMake targets for Qt modules
Use e.g. Qt6::Core instead of Qt::Core. This is better matching the find_package(Qt6 ...) call, and also avoids issues that the versionless targets have. Pick-to: 6.5 Task-number: QTBUG-113277 Change-Id: Ib80f885e9f73fb9ad54b9e9b22cae2318877dc07 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/quickcontrols/gallery/CMakeLists.txt')
-rw-r--r--examples/quickcontrols/gallery/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/examples/quickcontrols/gallery/CMakeLists.txt b/examples/quickcontrols/gallery/CMakeLists.txt
index baa7d948f1..fc5d14078c 100644
--- a/examples/quickcontrols/gallery/CMakeLists.txt
+++ b/examples/quickcontrols/gallery/CMakeLists.txt
@@ -83,17 +83,17 @@ qt_add_qml_module(galleryexample
)
target_link_libraries(galleryexample PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Quick
- Qt::QuickControls2
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Quick
+ Qt6::QuickControls2
)
if(UNIX AND NOT APPLE AND CMAKE_CROSSCOMPILING)
find_package(Qt6 REQUIRED COMPONENTS QuickTemplates2)
# Work around QTBUG-86533
- target_link_libraries(galleryexample PRIVATE Qt::QuickTemplates2)
+ target_link_libraries(galleryexample PRIVATE Qt6::QuickTemplates2)
endif()
install(TARGETS galleryexample