aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/eventcalendar/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2021-10-20 15:11:12 +0200
committerMitch Curtis <mitch.curtis@qt.io>2021-11-03 11:40:59 +0100
commitdbf7048ae265f43dc8b097dd55e6de21e53ed645 (patch)
tree2609d813e5a802f31bdb397ec9b0fc9cc7668918 /examples/quickcontrols2/eventcalendar/CMakeLists.txt
parentec9e2c047992ca7f12883de5128fa0e4e84733bf (diff)
Add calendar types
Formerly Qt.labs.calendar, then QtQuick.Calendar in the marketplace, this now returns as part of the controls module. [ChangeLog] Added types from Qt.labs.calendar/QtQuick.Calendar. Change-Id: I8a06c08e6520be1ba8f33c73ba174785724e99c2 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'examples/quickcontrols2/eventcalendar/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/eventcalendar/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/examples/quickcontrols2/eventcalendar/CMakeLists.txt b/examples/quickcontrols2/eventcalendar/CMakeLists.txt
new file mode 100644
index 0000000000..a5f417677d
--- /dev/null
+++ b/examples/quickcontrols2/eventcalendar/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Generated from eventcalendar.pro.
+
+cmake_minimum_required(VERSION 3.16)
+project(eventcalendar LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/eventcalendar")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Sql)
+find_package(Qt6 COMPONENTS Qml)
+
+qt_add_executable(eventcalendar
+ event.h
+ eventcalendar.cpp
+ eventmodel.cpp eventmodel.h
+ sqleventdatabase.cpp sqleventdatabase.h
+)
+set_target_properties(eventcalendar PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_link_libraries(eventcalendar PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Sql
+)
+
+qt_add_qml_module(eventcalendar
+ URI App
+ VERSION 1.0
+ QML_FILES
+ MonthGridDelegate.qml
+ eventcalendar.qml
+ RESOURCES
+ qtquickcontrols2.conf
+ NO_RESOURCE_TARGET_PATH
+)
+
+install(TARGETS eventcalendar
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)
+