aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/gallery/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-20 17:42:48 +0100
committerKai Köhne <kai.koehne@qt.io>2022-01-24 13:25:13 +0100
commit9d82f4bff8520c3f6db7790d9044c3dfc5cc84c0 (patch)
tree208f1e58e65083c7ddad2abdf1473679176fdaad /examples/quickcontrols2/gallery/CMakeLists.txt
parenta3924b9846f8f3412e6cfc3704f69488e64da98e (diff)
Improve examples CMakeLists.txt
- Remove # generated from xyz.pro comment from pro2cmake - Remove "# special case" markers for pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Pick-to: 6.3 Change-Id: I0d6bfb06c4b25e9921d3d2bf31d977150f12b31b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/quickcontrols2/gallery/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/gallery/CMakeLists.txt35
1 files changed, 14 insertions, 21 deletions
diff --git a/examples/quickcontrols2/gallery/CMakeLists.txt b/examples/quickcontrols2/gallery/CMakeLists.txt
index b3270205fa..3d689fe6b1 100644
--- a/examples/quickcontrols2/gallery/CMakeLists.txt
+++ b/examples/quickcontrols2/gallery/CMakeLists.txt
@@ -1,45 +1,38 @@
-# Generated from gallery.pro.
-
cmake_minimum_required(VERSION 3.16)
-project(gallery_controls2 LANGUAGES CXX) # special case
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+project(gallery_controls2 LANGUAGES CXX)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/quickcontrols2/gallery")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Quick)
-find_package(Qt6 COMPONENTS QuickControls2)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick QuickControls2)
-qt_add_executable(gallery_controls2 # special case
+qt_add_executable(gallery_controls2
gallery.cpp
)
-set_target_properties(gallery_controls2 PROPERTIES # special case
+
+set_target_properties(gallery_controls2 PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_link_libraries(gallery_controls2 PUBLIC # special case
+
+target_link_libraries(gallery_controls2 PUBLIC
Qt::Core
Qt::Gui
Qt::Quick
Qt::QuickControls2
)
-# special case begin
+
if(UNIX AND NOT APPLE AND CMAKE_CROSSCOMPILING)
- find_package(Qt6 COMPONENTS QuickTemplates2)
- # Work around QTBUG-86533
+ find_package(Qt6 REQUIRED COMPONENTS QuickTemplates2)
+
+ # Work around QTBUG-86533
target_link_libraries(gallery_controls2 PRIVATE Qt::QuickTemplates2)
endif()
-# special case end
# Resources:
set(qmake_immediate_resource_files
@@ -102,14 +95,14 @@ set(qmake_immediate_resource_files
"qtquickcontrols2.conf"
)
-qt6_add_resources(gallery_controls2 "qmake_immediate" # special case
+qt6_add_resources(gallery_controls2 "qmake_immediate"
PREFIX
"/"
FILES
${qmake_immediate_resource_files}
)
-install(TARGETS gallery_controls2 # special case
+install(TARGETS gallery_controls2
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"