aboutsummaryrefslogtreecommitdiffstats
path: root/examples/quickcontrols2/swipetoremove/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-24 13:26:43 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-08 16:25:53 +0000
commit833d8c305b8cc01ab2d7958a2ba5a061a9e966ef (patch)
tree379903422009964dd25182b99ef10249a4b59dbb /examples/quickcontrols2/swipetoremove/CMakeLists.txt
parent2d4f2f1f4a4ff2f6e6189d9206875927d529f4c2 (diff)
Conversion of QtQuickControls2 examples
Initial Conversion of QtQuickControls2 examples. Change-Id: I21ddf792d039dc26e4ba58d8592101eb131618d3 Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/quickcontrols2/swipetoremove/CMakeLists.txt')
-rw-r--r--examples/quickcontrols2/swipetoremove/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/examples/quickcontrols2/swipetoremove/CMakeLists.txt b/examples/quickcontrols2/swipetoremove/CMakeLists.txt
new file mode 100644
index 0000000000..d23619eed5
--- /dev/null
+++ b/examples/quickcontrols2/swipetoremove/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Generated from swipetoremove.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(swipetoremove LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Qml)
+
+add_qt_gui_executable(swipetoremove
+ swipetoremove.cpp
+)
+target_link_libraries(swipetoremove PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+# Resources:
+set(qmake_immediate_resource_files
+ "fonts/fontello.ttf"
+ "swipetoremove.qml"
+)
+
+qt6_add_resources(swipetoremove "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)
+
+
+install(TARGETS swipetoremove
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)