aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-01-15 10:45:18 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-01-18 09:45:44 +0100
commit12115bbda219a651ef86a4e91fd5e52eb54ed29b (patch)
tree08c17ec1b5064603ebf3943abd3147216026aeb9 /src/CMakeLists.txt
parent704df6f14137d7e91cccb6f895d07fabcdb10f69 (diff)
Quick.Layouts: Make plugin optional
This moves the Layouts types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Change-Id: I9b2b31a78b0e9ca8b6c0db1fc9272d9941c61814 Reviewed-by: Maximilian Goldstein <max.goldstein@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 18c5f50c01..25c2be3648 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,6 +16,7 @@ endif()
if(TARGET Qt::Gui AND QT_FEATURE_qml_animation)
add_subdirectory(quick)
add_subdirectory(quickshapes)
+ add_subdirectory(quicklayouts)
find_package(Qt6 ${PROJECT_VERSION} CONFIG COMPONENTS Test) # special case
if(QT_FEATURE_testlib AND TARGET Qt::Test) # special case