aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 12:22:35 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 13:26:00 +0100
commite9af4fcf54046d077b6792b25e080ffdacc3f327 (patch)
tree96248e03133d93d8b416033126ab274a107b549b /src/CMakeLists.txt
parent2fdf354c66cb650605e0349ebf1228f3aa43dacc (diff)
Qt.labs.animation: Make plugin optional
This moves the animation types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: I19bd864253941931706933f7e517bb31938e9cc2 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 54de0ba58b..db06625dfd 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,7 +8,6 @@ endif()
add_subdirectory(qmltyperegistrar)
add_subdirectory(qml)
add_subdirectory(qmlmodels)
-add_subdirectory(labs)
if(QT_FEATURE_qml_worker_script)
add_subdirectory(qmlworkerscript)
@@ -38,6 +37,8 @@ if(TARGET Qt::Gui AND QT_FEATURE_qml_animation)
endif()
endif()
+add_subdirectory(labs)
+
# special case begin
# These need to be included here since they have dependencies on the modules
# specified above.