aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 11:25:25 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 15:20:52 +0100
commitfb6158732b6615d26e7800a2a7821fe854363d29 (patch)
tree7ca4a7a9db0302a1572258a6644d291f02bf24b5 /src/CMakeLists.txt
parent2506938d829bf146e45e121116f870942c0453e1 (diff)
QtQuick.LocalStorage: Make plugin optional
This moves the LocalStorage types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: I57ae8dc45a9ef3d5221520f656a2475bca2eb453 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 25c2be3648..41efafb6d8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,6 +13,11 @@ if(QT_FEATURE_qml_worker_script)
add_subdirectory(qmlworkerscript)
endif()
+if(TARGET Qt::Sql)
+ add_subdirectory(qmllocalstorage)
+ endif()
+
+
if(TARGET Qt::Gui AND QT_FEATURE_qml_animation)
add_subdirectory(quick)
add_subdirectory(quickshapes)