aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-11-03 17:06:36 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-12 18:06:39 +0100
commit89f9ddc93fd8b2f6d2ca36f045d5a09a4813fb6c (patch)
tree2190983eca791c2b75d388811b5d9b462fc3b3ff /src/imports/CMakeLists.txt
parent8cdbcee614dbb34d4ac770bee1734c18ea27fa12 (diff)
CMake: Change Quick.Window into a pure Qml module
This fixes apps using Qt.Window with static Qt builds when deployed to a machine that doesn't have Qt installed. This will need a counterpart fix in qmake land. Change-Id: Ife11f9d1f1826e1188ef3dc3933af2f243860b6f Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/imports/CMakeLists.txt')
-rw-r--r--src/imports/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
index d2c8e5694f..9df5367295 100644
--- a/src/imports/CMakeLists.txt
+++ b/src/imports/CMakeLists.txt
@@ -36,3 +36,6 @@ endif()
if(QT_FEATURE_quick_path AND TARGET Qt::Quick)
add_subdirectory(shapes)
endif()
+# special case begin
+add_subdirectory(window)
+# special case end