aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/folderlistmodel/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 17:23:23 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 10:35:52 +0100
commiteb5bb9e7f547a7e222b5dbb848774639ab11f243 (patch)
tree7c4377e7b272025a4240e5707365a50b49898cc9 /src/imports/folderlistmodel/CMakeLists.txt
parent3fadfb2c3fa7d4b22d0d0269c645c1086fa56619 (diff)
Qt.labs.folderlistmodel: Make plugin optional
This moves the folderlistmodel types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: Iee84a4804a241aa1dee5f896a02ccc9f0ecc0d8d Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/folderlistmodel/CMakeLists.txt')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index f1e543ad9f..85a43061f4 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -9,16 +9,13 @@ qt_internal_add_qml_module(qmlfolderlistmodelplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlFolderListModelPlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
+ PLUGIN_OPTIONAL
SOURCES
- fileinfothread.cpp fileinfothread_p.h
- fileproperty_p.h
plugin.cpp
- qquickfolderlistmodel.cpp qquickfolderlistmodel.h
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
+ Qt::LabsFolderListModelPrivate
)
#### Keys ignored in scope 1:.:.:folderlistmodel.pro:<TRUE>: