aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/folderlistmodel
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-06-05 13:35:02 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-07-24 12:02:30 +0000
commit78254be6cbd239a3de332c5660b2c408d9f3e674 (patch)
treefeca8f2213db8da240158000b03a3d61b1f77469 /src/imports/folderlistmodel
parent55cc9396e0832d84ce231c0f608c2b6850d7ef78 (diff)
Build projects from src/import
Add support to build the projects under src/imports. All the CMakeLists.txt were generate with pro2cmake, except for src/imports/builtins. Change-Id: I06046ede82ba5b1e677e92b7548f543d020b0354 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports/folderlistmodel')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
new file mode 100644
index 0000000000..77f4702826
--- /dev/null
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Generated from folderlistmodel.pro.
+
+#####################################################################
+## qmlfolderlistmodelplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlfolderlistmodelplugin
+ TARGET_PATH "Qt/labs/folderlistmodel"
+ IMPORT_VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ SOURCES
+ fileinfothread.cpp fileinfothread_p.h
+ fileproperty_p.h
+ plugin.cpp
+ qquickfolderlistmodel.cpp qquickfolderlistmodel.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:folderlistmodel.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
+# TARGETPATH = "Qt/labs/folderlistmodel"
+# _LOADED = "qml_plugin"