aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/labsmodels
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-06-05 13:35:02 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-07-24 12:02:30 +0000
commit78254be6cbd239a3de332c5660b2c408d9f3e674 (patch)
treefeca8f2213db8da240158000b03a3d61b1f77469 /src/imports/labsmodels
parent55cc9396e0832d84ce231c0f608c2b6850d7ef78 (diff)
Build projects from src/import
Add support to build the projects under src/imports. All the CMakeLists.txt were generate with pro2cmake, except for src/imports/builtins. Change-Id: I06046ede82ba5b1e677e92b7548f543d020b0354 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports/labsmodels')
-rw-r--r--src/imports/labsmodels/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
new file mode 100644
index 0000000000..e0878cf405
--- /dev/null
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from labsmodels.pro.
+
+#####################################################################
+## labsmodelsplugin Plugin:
+#####################################################################
+
+add_qml_module(labsmodelsplugin
+ TARGET_PATH "Qt/labs/qmlmodels"
+ IMPORT_VERSION "1.0"
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Qml
+ Qt::QmlModels
+)
+
+#### Keys ignored in scope 1:.:.:labsmodels.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.0"
+# TARGETPATH = "Qt/labs/qmlmodels"
+# _LOADED = "qml_plugin"