aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/qtqml/.prev_CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-11-25 15:33:16 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2019-11-25 14:54:07 +0000
commitf500062e165975e112ea644da1d6a3d4c413be2a (patch)
treed7e92bcb689d53ab1046130250327974058ee7b4 /src/imports/qtqml/.prev_CMakeLists.txt
parentf1f395b37da163bce2dc3b5fc4e298bb4f56a3e7 (diff)
Post Merge Fixes
Change-Id: I13bc3aef318d8b497b01c61fcca7760abd96339a Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports/qtqml/.prev_CMakeLists.txt')
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt21
1 files changed, 18 insertions, 3 deletions
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index 827474f2fb..3f920616f5 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -1,5 +1,15 @@
# Generated from qtqml.pro.
+set(module_dynamic_qml_imports
+ QtQml.Models
+)
+
+if (QT_FEATURE_qml_worker_script)
+ list(APPEND module_dynamic_qml_imports
+ QtQml.WorkerScript
+ )
+endif()
+
#####################################################################
## qmlplugin Plugin:
#####################################################################
@@ -9,10 +19,8 @@ qt_add_qml_module(qmlplugin
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
CLASSNAME QtQmlPlugin
- IMPORTS
- QtQml.Models
- QtQml.WorkerScript
SKIP_TYPE_REGISTRATION
+ IMPORTS ${module_dynamic_qml_imports}
SOURCES
plugin.cpp
LIBRARIES
@@ -25,5 +33,12 @@ qt_add_qml_module(qmlplugin
#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
# CXX_MODULE = "qml"
+# DYNAMIC_QMLDIR = "module QtQml" "plugin qmlplugin" "classname QtQmlPlugin" "typeinfo plugins.qmltypes" "designersupported" "import QtQml.Models"
# IMPORT_VERSION = "2.$$QT_MINOR_VERSION"
# TARGETPATH = "QtQml"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qtqml.pro:QT_FEATURE_qml_worker_script:
+# DYNAMIC_QMLDIR = "import QtQml.WorkerScript"