aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/qtqml/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-01 16:03:00 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-01 14:07:24 +0000
commite60af03e2faee1b20cbbf722bcc57f06fcd793fe (patch)
tree0d9b1481515bbf7be5e5fcd6c63427088382ca7c /src/imports/qtqml/CMakeLists.txt
parent5b0db35531756e2bc060573fc119d703e0fa14e9 (diff)
Update qml modules
Updated qml modules to be compatible with the latest changes to add_qml_modules. Change-Id: I3342a1375bfa64a16fb0c54f812c56bad173f73c Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports/qtqml/CMakeLists.txt')
-rw-r--r--src/imports/qtqml/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index 9f638c27b8..50ee3350c6 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -5,9 +5,10 @@
#####################################################################
add_qml_module(qmlplugin
- INSTALL_QML_FILES
- TARGET_PATH "QtQml"
- IMPORT_VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CPP_PLUGIN
+ URI "QtQml"
+ VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ RESOURCE_PREFIX "/qt-project.org/imports"
SOURCES
plugin.cpp
LIBRARIES